Choose names that clearly communicate purpose, type, and intent rather than generic or ambiguous identifiers. Names should be self-documenting and help other developers understand what the code does without additional context.
Key principles:
filePaths
instead of files
, selectedGroupIndex
instead of selectedGroup
)getKiloBaseUri
instead of KiloBaseUri
)kilocodeToken
)Example improvements:
// Instead of generic names:
const cache = new Map<string, Promise<string>>() // unclear what string represents
function KiloBaseUri(options: ApiHandlerOptions) // unclear if this gets, sets, or creates
// Use descriptive names:
const cache = new Map<string, Promise<string>>() // with comment: kilocodeToken -> model promise
function getKiloBaseUri(options: ApiHandlerOptions) // clearly indicates this retrieves a URI
// Parameter clarity:
files?: string[] // ambiguous
filePaths?: string[] // clearly indicates these are file paths
This approach reduces cognitive load, improves code maintainability, and makes the codebase more accessible to new team members.
Enter the URL of a public GitHub repository